Arista VXLAN

From HackerNet
Jump to: navigation, search

Virtual Extensible LAN (VXLAN) är en network virtualization technology. VXLAN bridging tillhandahåller layer 2 konnektivitet för end systems över en routat infrastruktur. För att koppla ihop end systems i olika subnät krävs VXLAN routing. Det kan göras både symmetriskt och asymmetriskt, dvs om samma VNI används i båda trafikriktninger eller ej. Default för enkapsulerade paket mellan VTEP:ar används UDP port 4789. Däremot kan control plane göras på olika sätt, se nedan. Aristas VXLAN går att kombinera med MLAG. Se även Cisco VXLAN.

Konfiguration

Initial setup. VTEP-IP måste vara nåbar från alla andra VTEP:ar.

interface Loopback0
 description VTEP
 ip address 10.0.0.10/32

interface Vxlan1
 vxlan source-interface Loopback0
 vxlan udp-port 4789

Skapa vlan och mappa med VNI.

vlan 100

interface Vxlan1
 vxlan vlan 100 vni 10100

Verify

show interface vxlan 1
show vxlan address-table

Flood and Learn

Ange IP-adresser till alla VTEP:ar. Man kan även ange den lokala vtep-ip:n i flood-listan, den kommer att accepteras i konfen men ignoreras i praktiken.

interface Vxlan1
 vxlan vlan 100 flood vtep 10.0.0.11 10.0.0.12

CVX

CloudVision eXchange (CVX) kan automatiskt synkronisera VTEP:arna och nödvändiga HER flood-lists. CVX synkroniserar alla MAC-adresser så fort en switch lärt sig dem på någon lokal port.

interface vxlan1
 vxlan source-interface Loopback0
 vxlan udp-port 4789
 vxlan control-service

management cvx
 source-interface lo0
 server host 10.0.0.100
 no shut

Standalone CVX VXLAN service on EOS

interface Loopback0
 ip address 10.0.0.100/32

config
 cvx
  no shutdown
  service vxlan
   no shutdown

Verify

show cvx 
show cvx connections
show vxlan controller status
show vxlan controller address-table received

EVPN

Arista implementerar EVPN VXLAN routing i symmetric mode. Se även Cisco EVPN.

Command to enable EVPN BGP agent on the nodes

service routing protocols model multi-agent
router bgp 100
 neighbor 10.0.0.20 remote-as 100

 vlan 100
  rd 100:10
  route-target import 100:10
  route-target export 100:10
  redistribute learned

 address-family evpn
  neighbor 10.0.0.20 activate

Verify

show bgp evpn route-type mac-ip

Multitenancy routing

with anycast gateway

vrf definition Tenant1
 rd 100:1

ip routing vrf Tenant1
ip route vrf Tenant1 0.0.0.0/0 10.0.0.1

interface Vlan100
 vrf forwarding Tenant1
 ip address virtual 10.0.0.10/24

interface Vlan101
 vrf forwarding Tenant1
 ip address virtual 10.0.101.1/24

NSX

Arista-switchar kan agera VTEP:s för NSX. Ta certet och importera i NSX Manager.

show hsc certificate
show hsc status