VyOS

From HackerNet
Jump to: navigation, search

VyOS är ett Linux-baserat network operating system med mjukvaru-routing, firewall och VPN funktionalitet. Det är en community fork av Vyatta Core med JunOS-liknande syntax och bygger på Debian och Quagga routing engine. Det har bl.a. stöd för DMVPN, VXLAN, OSPF, BGP och IPv6. Men saknar tyvärr stöd för Multicast routing och MPLS. Det finns möjlighet att installera FastNetMon direkt på en VyOS-router, se länk [1]

Installation

Ladda ner OVA alternativt installera från iso. PW: vyos

vyos@vyos:~$ install image 

Konfiguration

Byt till konfigurationsläge.

configure

Ändringar måste commitas. För att spara till startup config används save.

commit
save

Show run

show conf

Show run kommandon

show configuration commands

SSH

set service ssh port '22'

Live logging

monitor log

System

set system domain-name hackernet.se
set system host-name vyos01
set system name-server 208.67.222.222
set system name-server 208.67.220.220
set system time-zone Europe/Stockholm

Interface

configure
set interfaces ethernet eth0 address '10.0.0.1/24'
set interfaces ethernet eth0 description 'INSIDE'
show interfaces

Default route

set protocols static route 0.0.0.0/0 next-hop 10.0.10.1 distance '1'

Verify

show ip route

Comments
Man kan lägga in kommentarer var som helst i konfigurationen.

comment path-config-section "comment"

Default editerar man från top level ([edit]) men för att undvika att alltid skriva långa kommandon kan man ställa sig var som helst i strukturen och använda relativa paths. "up" är för att backa.

edit interfaces ethernet eth0 
set address '10.0.0.1/24'

NAT

Overload/PAT

set nat source rule 10 outbound-interface eth0
set nat source rule 10 source address 10.0.0.0/24
set nat source rule 10 translation address masquerade